Author Topic: We are having some problems with the site!  (Read 8582 times)

Bjørn Rørslett

  • Fierce Bear of the North
  • Administrator
  • ***
  • Posts: 8245
  • Oslo, Norway
Re: We are having some problems with the site!
« Reply #15 on: October 22, 2016, 23:49:02 »
The numbers visiting sloooowly increase. This DNS outage is really worrisome.

The proactive measure that will work even with a repetition of Friday's massive DDOS attack waves is doing the name resolution locally to prevent being dependent on DNS servers downstream.

All the major OS platforms have a HOSTS file somewhere that might be pressed into service for resolving domain name-IP address right there on your own computer. It is largely a historic relic these days, but don't underestimate its usefulness. As NG has a static IP, all that is required is adding the following line to your HOSTS file, using a text editor such as Notepad or Gedit or what is available on your platform,

162.210.51.116 nikongear.net


On most systems you have to run this action as an Administrator with elevated privileges.

Once the HOSTS file is updated, accessing NG in your browser should work. Perhaps it is a good idea to flush the browser cache first (won't do any harm).

Airy

  • NG Supporter
  • **
  • Posts: 1722
    • My pics repository
Re: We are having some problems with the site!
« Reply #16 on: October 23, 2016, 00:25:48 »
I'm back, thanks to an email from Erik.

:)
Airy Magnien

Erik Lund

  • Global Moderator
  • **
  • Posts: 4729
  • Copenhagen
    • ErikLund.com
Re: We are having some problems with the site!
« Reply #17 on: October 23, 2016, 01:01:26 »
More and more are joining ;)

Suggested alternative Google's DNS servers to:  8.8.8.8 and 8.8.4.4 from Bill Symmes
Erik Lund

Akira

  • Homo jezoensis
  • NG Supporter
  • **
  • Posts: 7586
  • Tokyo, Japan
    • Akira on flickr
Re: We are having some problems with the site!
« Reply #18 on: October 23, 2016, 03:15:21 »
Venerable moderators, thanks!  My computer can find my home now.  :)
"The eye is blind if the mind is absent." - Confucius

"Limitation is inspiration." - Akira

Fons Baerken

  • NG Supporter
  • **
  • Posts: 5248
    • https://www.flickr.com/photos/fonsbaerken/
Re: We are having some problems with the site!
« Reply #19 on: October 23, 2016, 07:30:19 »
Thanks for the mail, good luck!

Roland Vink

  • NG Member
  • *
  • Posts: 997
  • Nikon Nerd from New Zealand
    • Nikon Database
Re: We are having some problems with the site!
« Reply #20 on: October 23, 2016, 09:17:12 »
When nothing of the above helps, put an entry into your HOSTS file to avoid DNS issues external to your own local network [...]
Worked for me, perfect.

I also received two emails from Eric, and tried the suggestions first. It worked but access to NG was very slow, almost as if the browser (Chrome) had to try twice before succeeding, and occasionally it still couldn't load the page.

Fons Baerken

  • NG Supporter
  • **
  • Posts: 5248
    • https://www.flickr.com/photos/fonsbaerken/
Re: We are having some problems with the site!
« Reply #21 on: October 23, 2016, 10:17:09 »
There are still quirks.
Page doesnt always load, or refresh, giving an offline error.

Bjørn Rørslett

  • Fierce Bear of the North
  • Administrator
  • ***
  • Posts: 8245
  • Oslo, Norway
Re: We are having some problems with the site!
« Reply #22 on: October 23, 2016, 10:29:58 »
We might have discovered potential issues with the DNS servers of our hosting provider. I'm writing a support ticket as we speak.

It is important that the NG site is accessed with the basic URL http://nikongear.net, no 'www' in front. That is part of the residual problems we need to sort out after the havoc. Some browsers apparently like to tack on a 'www' prefix in its first attempt to locate a web page, and that might explain some of the slowness that occasionally creep in. Plus of course the fact that the general load on the OpenDNS serves has increased tremendously the last couple of days.

Akira

  • Homo jezoensis
  • NG Supporter
  • **
  • Posts: 7586
  • Tokyo, Japan
    • Akira on flickr
Re: We are having some problems with the site!
« Reply #23 on: October 23, 2016, 12:09:58 »
There are still quirks.
Page doesnt always load, or refresh, giving an offline error.

I realized the images hosted from flickr tend to load slow and some fail to appear.  Even accessed directly, flickr has been slowed down possibly since it had been purchased by Verizon.
"The eye is blind if the mind is absent." - Confucius

"Limitation is inspiration." - Akira

Hugh_3170

  • NG Member
  • *
  • Posts: 1006
  • Melbourne, Australia (at the moment)
Re: We are having some problems with the site!
« Reply #24 on: October 23, 2016, 13:44:03 »
Thanks Erik and thanks Bjørn.  Am now in from OZ.
Hugh Gunn

Akira

  • Homo jezoensis
  • NG Supporter
  • **
  • Posts: 7586
  • Tokyo, Japan
    • Akira on flickr
Re: We are having some problems with the site!
« Reply #25 on: October 23, 2016, 19:34:34 »
For some folks, the site has become inaccessible again even after re-setting the DNS server.  I can still access here, though.  Have there been any new problem?
"The eye is blind if the mind is absent." - Confucius

"Limitation is inspiration." - Akira

Bent Hjarbo

  • NG Supporter
  • **
  • Posts: 767
  • Hvidovre, Denmark
    • Hjarbos hjemmeside
Re: We are having some problems with the site!
« Reply #26 on: October 23, 2016, 19:37:09 »
Had to use the hosts solution as the new DNS's seems unreliable at the moment.
Only problem, can't use my phone/tablet  :(

Bjørn Rørslett

  • Fierce Bear of the North
  • Administrator
  • ***
  • Posts: 8245
  • Oslo, Norway
Re: We are having some problems with the site!
« Reply #27 on: October 23, 2016, 19:42:29 »
Our hosting supplier site5.com relies on DNS services through Dyn, the US company that was targeted in the recent DDOS attacks. Thus although the OpenDNS serves do their service, they depend on information from site5.com whenever the DNS lease is to be refreshed.

Also at present nikongear.net apparently has been decoupled from its DNS, thus using the HOST file approach is more or less mandatory and required to get access.

For unknown reasons I cannot update the missing DNS records myself from the NG siteAdm panel. It should be possible, but I only get laconic error messages of the most unhelpful nature ('there has been an error' sic). Thus I have lodged support ticket(s) with site5 and hope they can sort the mess quickly.

Akira

  • Homo jezoensis
  • NG Supporter
  • **
  • Posts: 7586
  • Tokyo, Japan
    • Akira on flickr
Re: We are having some problems with the site!
« Reply #28 on: October 23, 2016, 19:57:14 »
Hmm, that is strange.  I wonder why then I can access here without problem?  I only applied the initial solution provided by you administrators...

The notification is still not working, though.
"The eye is blind if the mind is absent." - Confucius

"Limitation is inspiration." - Akira

Bjørn Rørslett

  • Fierce Bear of the North
  • Administrator
  • ***
  • Posts: 8245
  • Oslo, Norway
Re: We are having some problems with the site!
« Reply #29 on: October 23, 2016, 20:02:05 »
Afraid notification will not work until we have solved the pesky DNS issues of NG at the hosting site. Currently NG is blissfully unaware of the world around itself and has lost any memory of its mail server.

The OpenDNS servers we recommended will occasionally update their caches and at that point they can lose track of NG if the local DNS isn't co-operative due to DDOS etc. I think this is the reason members now start to have connectivity issues again.

As soon a we get the local DNS records updated, things ought to run more smoothly and ordinary DNS servers might be pressed into service too.